校园网无线网络投标书

陕西国防工业职业技术学院双核心校园

组建项目

投标单位:西安八一网络科技有限公司

投标单位全权代表:王伟凯

2017年10月20日

致:陕西国防工业职业技术学院

首先感谢贵公司对我公司的信任,使我们公司有机会参与贵单位的投标,我们深感荣幸并表示真诚的谢意。

我公司仔细研究了贵单位工程的招标文书及有关资料,同时对施工现场及周围环境进行调查了解,经过反复论证、认真分析,愿意承担贵单位所发的文件中的各项条款,同时做出了符合该工程工期、质量等方面的施工安排,组织技术熟练、质量过硬、善打硬仗的施工队伍负责该工程的所需材料的施工。我们对该单位工程的设计方案和预算进行了汇总,在后面条条列出。

如信任我们公司,由我们公司中标承担该工程,我们会完全按照标书中的设计进行并兑现标书中的所有承诺,为贵单位做出我们的贡献。

投标价格:20万元

投标时间:1个月

目录

一、需求分析负责人

二、双核心校园网络组建拓扑规划图

1、双核心校园网规划设计杨震

2、RIP动态路由协议刘玉梅

3、网络冗余设计鸟英

1)链路聚合

2)多生成树协议(MSTP)

3)虚拟路由器冗余协议(VRRP)

4、双链路接入Internet王伟凯

5、网络管理设计王启超

1) 基于Telnet/SSH的远程登录管理

2) 基于SNMP的网络管理

3) 交换机集群管理

4) 镜像技术及应用

5) Qos及配置管理

三、双核心校园网项目材料分项报价表陆和晨

四、法定代表人授权书

五、培训服务及售后服务

一、需求分析

本工程是位于陕西国防工业职业技术学院教学楼的双核心校园网组建工程,建筑结构是由一栋办公图书楼、三栋教学实训楼和六栋学生宿舍楼组成,现在各建筑物内局域网已建成,现要将各楼宇局域网互联,建设成高可靠性的校园网。网络建设需求如下:

(1)校园局域网内可以实现多媒体教学、视频点播、办公自动化、资源共享等。

(2)校园网要具有一定地稳定性、可用性和健壮性。

(3)校园网内办公图书楼和教学实训楼用户可访问教育网免费资源。

(4)校园网内的所有用户均可访问Internet资源,需要双出口。

(5)在网络管理方面要实现易于管理、方便维护等可管理性。

(6)应客户要求,本次项目所用所有设备,全部采用国产。

根据项目需求及分析,为增强网络的稳定性、健壮性,本项目拓扑结构采用冗余层次化拓扑结构,两个核心交换机之间使用聚合链路相连接,可以提供冗余,增加宽带。根据用户需求,不同的流量网络出口不同,所以本项目应规划为双出口网络:Cernet(教育网)和ISP,所以需要改变内网流量的走向,需配置策略路由等功能;核心交换机和出口路由器应配置冗余备份、负载均衡功能,可使用VRRP、MSTP等技术来实现,另外路由器上还需配置NAT。对于路由规划,内网路由配置针对小型网络的动态路由协议RIP(路由信息协议),即核心交换机和汇聚层交换机上配置RIP。

二、双核心校园网系统图

1、双核心校园网规划设计

双核心网络冗余结构设计

冗余设计的手段是在网络中安装并行的,备用的组件,例如路由器,核心交换机,电源,

如图所示,备用的核心交换机A1在核心交换机A2出现故障时,仍然能将来自汇聚层交换机B2的数据接收到核心层。

校园网无线网络投标书

(2)备用链路

当网络中的某条主路径出现故障时,会影响到网络的互联性,为了保持网络的畅通,冗余网络设计提供了备用链路的设计。备用链路是由路由器、交换机以及路由器与交换机之间的独立备用链路构成的,它是主路径上的设备与链路的重复设置。

本项目中,采用非对称性备份链路设计方案。非对称性备份链路设计方案中备份链路提供较小或相等的带宽,只在主链路出现故障时备份链路才生效。如上图,L2可提供较小的带宽,在主链路L1和设备A1运行正常的情况下,备份链路L2可以不运行。

(3)校园网双核心双出口网络拓扑

该网络拓扑中,为增强网络的稳定性、健壮性,在网络核心层采用了增加网络设备的冗余方法,采用双核心交换机结构,为网络的核心增强了可用性。而在网络出口也采用了双出口的Internet接入方案,满足用户不同内网流量访问不同网络资源的需求。

校园网无线网络投标书

B、IP地址规划设计

校园网无线网络投标书

校园网无线网络投标书

校园网无线网络投标书

校园网无线网络投标书

4.2 RIP动态路由协议及其配置

校园网无线网络投标书

3、对两台出口设备,两台核心交换机以及四台汇聚层交换机上的RIPV2配置

Rip的特点:仅和相邻的路由器交换信息。如果两个路由器之间的通信不经过另外一个路由器,那么这两个路由器是相邻的。RIP规定,不相邻的路由器之间不交换信息。路由器交换的信息是当前本路由器所知道的全部信息,即自己的路由表。按固定时间交换路由信息,如每隔30s,然后路由器根据收到的路由信息更新路由表。RIP只适用于小型互联网,如小型的校园网和局域网。

建立此拓扑的作用:使两台相邻的路由器之间通过rip动态路由协议,实现校园网或者区域网中两台路由器之间路由信息的互通。

本项目中RIPV2的配置: router rip(启动rip动态路由协议)

Version2 (声明rip版本2)

No auto-summary (关闭自动汇总)

Network 172.17.0.0 (通告网段)

RIPV2的管理及排错

用sh ip route查看路由信息

通过debug ip rip命令进行调试,以便排错

问题:为什么用RIPV2配置?

答:适用分类路由,在它的路由更新中并不带有子网信息;

Ripv2是一种无类别路由协议;

Ripv2报文中携带掩码信息,支持VLSM和CIDR;

Ripv2支持以组播方式发送路由更新报文,组播地址为224.0.0.9,减少网络与系统资源消耗;(优化路由更新发送地址,由广播变成组播,支持触发更新功能。大大缩减协议流量)

Ripv2支持对协议报文经行验证,并提供明文验证和MD5验证方式,增强安全性。(增加了验证机制)

校园网无线网络投标书

4.3网络冗余设计

1、链路聚合

本项目中,我们将在核心交换0/8两个物理端口捆绑成一个逻辑端口,该逻辑端

口带宽为两个物理端口带宽机L1和L2之间采用链路聚合,L1与L2分别通过两

个物理端口E0/0/5和E0/0/6连接,如果在两个交换机上分别作链路聚合的配置,

即可把E0/0/5和E0/0/6之和,那么两个交换机这时就是通过一条逻辑通道连接

的了,该逻辑通道中的任一物理链路还可起到链路备份作用。

校园网无线网络投标书

2、多生成树协议MSTP

校园网无线网络投标书

本次项目中,采用的MSTP技术,MSTP设置VLAN映射表(即VLAN和生成树的对应关系表),把VLAN和生成树联系起来;通过增加“实例”(将多个VLAN整合到一个集合中)这个概念,将多个VLAN捆绑到一个实例中,以节省通信开销和资源占用率。MSTP把一个交换网络划分成多个域,每个域内形成多棵生成树,生成树之间彼此独立。

MSTP将环路网络修剪成为一个无环的树型网络,避免报文在环路网络中的增生和无限循环,同时还提供了数据转发的多个冗余路径,在数据转发过程中实现VLAN数据的负载分担。

3、虚拟路由冗余协议(VRRP)

VRRP报文是封装在IP报文上的,支持各种上层协议,同时VRRP还支持将真实接口IP地址设置为虚拟IP地址。

在本项目中,采用双核心结构,两台核心交换机采用链路聚合方式连接,可以起到负载均衡的作用。在核心交换机L1和L2上,配置VRRP,为各VLAN用户提供网关的冗余。如,VLAN10的主路由设备为L1,备份路由设备为L2,当主L1故障或跟踪的接口故障时,L2将成为VLAN10主路由设备。

4.4双链路接入Internet

校园网无线网络投标书

保证Internet接入的稳定性对于校园网来说是重要的。采用一条Internet接入,也就是说使用一个ISP的链路无法保证它提供的Internet链路的持续可用性,从而可能导致Internet访问和web服务器的中断,而中断带来的影响是不可估量的。多链路冗余起到在多个运营商之间故障的转移,但是网络边界设备作为内外网的接入点,当设备出现故障便会导致内外网之间的网络业务的全部中断,引起单点故障影响业务正常运行。因此在网络接入点部署多台设备形成备份/冗余是非常必要的,其中一台设备发生故障时,数据便会切换到另外一台设备上继续传输,而且还可以做设备性能的叠加增强。

(1)策略路由

三层设备在转发数据包时一般都基于数据包的目的地址,策略路由可以不仅仅依据目的地址转发数据包,它可以基于源地址、数据应用、数据包长度等。这样转发数据包更灵活。使用策略路由可以设置数据包的行为,比如下一跳、下一接口等,这样在存在多条链路的情况下,可以根据数据包的应用不同而使用不同的链路,进而提供高效的负载平衡能力。策略路由一般针对的是接口入(in)方向的数据包。

为了保证校园网内办公图书楼以及教学实训楼流量可以访问教育网免费资源,而其他流量或访问资源均通过ISP访问,需要在核心交换机L1和L2上配置NAT和策略路由。

172.17.16.0/21、172.17.24.0/21和172.17.32.0/21是校园网内部地址,其中

172.17.160/21为办公图书楼网络、172.17.24.0/21.为教学实训楼网络、172.17.32.0/21为学生宿舍楼网络;202.110.33.0/24表示ISP的地址,101.220.22.0/24表示cernet公网地址,ISP出口设备的内口ip地址为172.17.0.1/30,cernet出口设备内口ip地址为172.17.1.1/30。、

核心交换机上的配置:

!配置校园网内访问教育网资源的访问控制列表

access-list 110 permit ip 172.17.16.0 0.0.7.255 any

access-list 110 permit ip 172.17.24.0 0.0.7.255 any

access-list 110 deny ip any any

!配置基于所有教育网的国内站点(免费流量)的访问控制列表

access-list 112 permit ip any 61.140.0.0 252.252.0.0

access-list 112 permit ip any 61.149.0.0 252.255.0.0

... ...

access-list 112 permit ip any 211.152.0.0 252.255.128.0

access-list 112 permit ip any 211.167.64.0 252.255.192.0

access-list 112 permit ip any 211.167.128.0 252.255.224.0

access-list 112 permit ip any 211.167.192.0 252.255.192.0

access-list 112 deny ip any any

!配置策略路由,特定网段的所有流量都经由cernet出口设备到教育网,其它的流量经ISP 出口设备到Internet

route-map policy1 permit 10 !定义策略路由policy1,用于实现负载分担和备份

match ip address 110 !匹配访问列表110,办公图书楼以及教学实训楼流量

match ip address 112 !同时匹配列表112,目标地址为教育网免费资源

set ip nest-hop 172.17.2.1 !设置下一跳为171.17.2.1,即cernet出口设备与cat4500E-1的连接口

set ip default next-hop 172.17.0.1 !如果cat4500E-1和cernet出口设备之间的链路down掉了,就使用默认的下一跳,也就是ISP出口设备

route-map policy1 permit 20 !不满足序列号10规则的,就匹配序列号20规则

set ip next–hop 172.17.0.1 !除办公图书楼、教学实训楼外的流量,则下一跳为ISP 出口设备

set ip default next-hop 172.17.2.1 !如果cat4500E-1和ISP出口设备之间的链路down 掉了,就使用默认的下一跳,也就是cernet出口设备

!完全保证没有非授权流量从Cernet流出,应当把中国教育科研网的免费地址访问控制列表(即上文中的 access–list 112访问控制列表)应用连接到cernet出口设备的端口。

Ip access-group 112

!将提供负载均衡和备份的路由策略应用于cat4500E-1的内网入接口。

Ip policy route-map policy1

(2)ISP出口设备配置:配置ISP出口设备与核心交换机cat4500E-1连接接口f0/0,与核心交换机cat4500E-2连接接口f0/1,与ISP设备连接接口为s0/0。配置如下:interface f0/0

ip address 172.17.0.1 255.255.255.252

ip nat inside

ip nat pool my-isp 202.110.33.10 202.110.33.40 !设置对外访问地址

ip nat inside source route-map ISP-a pool my-isp overload

access-list 111 permit ip 172.17.0.0 0.0.255.255 any !指定NAT范围

route-map ISP-a permit 10 !源地址为局域网内所有地址且匹配s0/0口路由的策略

match ip address 111

match interface s0/0

interface f0/1

ip address 172.17.3.1 255.255.255.252

ip nat inside

interface s0/0

ip address 202.110.33.1 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 202.110.33.2 !配置默认路由

(3)cernet出口设备配置。配置cernet出口设备与核心交换机cat4500E-1连接接口f0/1,与核心交换机cat4500E-2连接接口f0/0。配置如下:

interface f0/0

ip address 172.17.1.1 255.255.255.252

interface f0/1

ip address 172.17.2.2 255.255.255.252

ip nat inside

ip nat pool my-edu 101.220.22.20 101.220.22.30 !设置对外访问地址

ip nat inside source route-map cernet-a pool my-edu overload

access-list 110 permit ip 172.17.16.0 0.0.7.255 any

access-list 110 permit ip 172.17.24.0 0.0.7.255 any

access-list 110 deny ip any any

access-list 112 permit ip any 61.140.0.0 255.252.0.0

access-list 112 permit ip any 61.149.0.0 255.252.0.0

... ...

access-list 112 permit ip any 211.152.0.0 255.252.128.0

access-list 112 permit ip any 211.67.64.0 255.252.192.0

access-list 112 permit ip any 211.167.128.0 255.252.224.0

access-list 112 permit ip any 211.167.192.0 255.252.192.0

access-list 112 permit ip any any

4.5、网络管理设计

1.基于Telnet/SSH的远程登录管理

交换机的管理方式基本分为两种:带内管理和带外管理。Telnet协议是TCP/IP

协议族中的一员,是Internet远程登录服务的标准协议和主要方式。SSH(Secure

Shell)为建立在应用层和传输层基础上的安全协议。

2.基于SNMP的网络管理

SNMP可做的工作很多,比如以下几类:

以图表的方式显示路由器/交换机的带宽使用情况,可以按端口,数据流向等分类。

以图形方式显示网络错误(比如CRC错误).

某个端口出现问题时可以发送警告信息给管理员。

3.交换机集群管理

交换机集群技术可以将分布在不同地理范围内的交换机逻辑地组合到一起,可以进行统一的管理。

4镜像技术及应用

镜像技术是把交换机的一个或多个端口(或VLAN)的流量完全复制一份,从另外一个端口(目的端口)发出去,以便网络管理人员从目的端口通过分析源端口的流量来实现对网络的监听。

镜像的作用主要是为了给某种网络分析器提供网络数据流。它既可以实现一个VLAN中若干个源端口向一个监控端口镜像数据,也可以从若干个VLAN向一个监控端口镜像数据。源端口的 E0/0/2~5号端口上流转的所有数据均被镜像至E0/015号监控端口,而数据分析设备通过监控端口收到了所有来自 E0/0/2~5上号端口的数据,如下图所示:

校园网无线网络投标书

5.Qos及配置管理

QoS(服务质量)是网络的一种安全机制,是用来解决网络延迟和阻塞等问题的一种技术。在正常情况下,如果网络只用于特定的无时间限制的应用系统,并不需要Qos,但是对关键应用和多媒体应用就十分必要。当网络过载或阻塞时,QoS能确保重要业务量不延迟或丢弃,同时保证网络的高速运行。

通过本任务的学习和技能训练,我们应该能规划设计网络中的网络中的主要设备的网络管理方法,理解和掌握网络中的设备的支持,Telnet/SSH远程管理的配置,基于SNMP网络管理协议的配置,交换机集群管理的配置等,并了解端口镜像,QoS的用用及配置管理。

三、双核心校园网项目材料分项报价表

双核心校园项目材料分析报价表

校园网无线网络投标书

法定代表人授权书

本授权书声明:注册于中国的八一网络科技有限公司,王伟凯代表本公司授权业务部长刘玉梅为本公司的合法代理人,就八一网络科技有限责任公司的采购(含投标和转为其他方式),以本公司名义处理一切与之有关的事务。

本授权书于2017年10月20日签字生效,特此声明。

法定代表人签字____王伟凯___________________

被授权人签字______刘玉梅_________________________

公司盖章:

附:

被授权人姓名:刘玉梅

职务:业务部长

详细通讯地址: XXXXXX

邮政编码: XXXXXX

传真: XXXXXX

电话: XXXXXX

培训服务及售后服务

××××:

西安市八一网络科技有限公司将针对此项目单独设立一个技术培训小组,并由技术部经理和策划部经理及两个项目主管直接负责此项目,安排出我公司的精英人员来进行专业培训。在培训过程中由技术部经理进行全天候的跟班服务,随时处理培训过程出现的问题,保证双核心校园网组建项目的合格率在二万分一以内。

验收方案:

西安市八一网络科技有限公司将针对此项目组织专人配合西安市陕西国防工业职业技术学院对此项目进行验收,对在此项目实施过程出现的一些技术问题进行及时的沟通和交流,以免出现差错。并由项目经理定期的进行自我检查,由我公司项目经理先进行自我验收,然后再交付此项目给陕西国防工业职业技术学院进行验收,以保证项目建设的质量。

服务方案:

承诺在双核心校园网组建项目过程中公司成立专门售后服务小组,派专人进行维修,以免出现设备上的问题。设立两部专线电话(××××××××××××)和项目经理手机(××××××××××)与客户进行沟通联系。免除用户后顾之忧。

履约保证金保函

致: 陕西国防工业职业技术学院

合同履约保函

本保函作为贵方与八一网络科技有限公司(以下简称卖方)于_2017_年_10__月__20__日就双核心校园网组建工程项目(以下简称项目)项下提供设备(以下简称货物)签订合同的履约保函。

______中国银行_________ (以下简称银行)无条件地、不可撤销地具结保证本行、其继承人和受让人无追索地向贵方以_____支票____________支付总额不超过_________________,即相当于合同价格的5%,并以此约定如下:

1.只要贵方确定卖方未能忠实地履行所有合同文件的规定和双方此后一致同意的修改、补充和变动,包括更改和/或修补贵方认为有缺陷的货物(以下简称违约),无论卖方有任何反对,本行将凭贵方关于卖方违约说明的书面通知,立即按贵方提出的累计总额不超过上述金额的款项和按贵方通知规定的方式付给贵方。

2.本保函项下的任何支付应为免税和净值。对于现有或将来的税收、关税、收费、费用扣减或预提税款,不论这些款项是何种性质和由谁征收,都不应从本保函项下的支付中扣除。

3.本保函的条款构成本行无条件的、不可撤销的直接责任。对即将履行的合同条款的任何变更、贵方在时间上的宽限、或由贵方采取的如果没有本款可能免除本行责任的任何其它行为,均不能解除或免除本行在本保函项下的责任。

4.本保函在本合同规定的保证期期满前完全有效。

谨启

出具保函银行名称____ 中国银行_________________________

签字人姓名和职务_________XXXXX____________________

签字人签名___________________XXX________________

公章___________________________________