H3C配置导入导出总结

H3C配置导入导出

一、h3c配置远程登录

1、服务器端配置(下面4步没有先后顺序)

1)开启远程登录服务

[h3c]telnet server enable 开启远程登录

2)创建telnet用户

[h3c]local-user h3c 创建用户名h3c

[h3c-luser-h3c]password cipher/simple h3c 为h3c创建密文/明文显示的密码

[h3c-luser-h3c]service-type telnet 定义该用户的服务类型为telnet

[h3c-luser-h3c]authorization-attribute level 3授权当前用户的命令行级别为3级——管理级P40

3)设定远程登录用户属性

[h3c]user-interface vty 0 4 设置虚拟用户端口

[h3c-ui-vty0-4]authentication-mode scheme 设定远程登录用户的登录方式使用用户名和密码

[h3c-ui-vty0-4]user privilege level 3 设置远程登录用户登录后的最高级别 4)配置IP地址

[h3c]interface vlan-interface 1

[h3c-vlan-interface1]ip address 192.168.1.1 24

2、客户端口配置

1)配置IP地址

192.168.1.2/24

3、登录

开始——程序——附件——命令提示符——telnet 192.168.1.1

二、导出配置文件

1、保存配置:

1)显示保存的配置:Display saved-cofiguration(结果是:配置文件不存在)

2)保存配置文件:Save(将current-configuration容保存到saved-configuration中,文件名是:startup.cfg。保存过程中先:Y确认保存,再确认使用默认文件名。此时再显示:此时可以看到配置文件容。)

说明:

1)移除保存的配置文件:reset saved-cofiguration(再显示时,提示:配置文件不存在) 2)重启设备:reboot

交换机重启时:直接确认为清除current-configuration

路由器重启时:直接确认为保存current-configuration

3)路由器的默认配置中g0/0口ip为192.168.1.1,telnet用户名为admin

2、创建ftp用户

[h3c]local-user h3c1 创建用户名h3c1

[h3c-luser-h3c]password cipher/simple h3c1 为h3c1创建密文/明文显示的密码

[h3c-luser-h3c]service-type ftp 定义该用户的服务类型为ftp

[h3c-luser-h3c]authorization-attribute level 3授权当前用户的命令行级别为3级

3、开启远程登录服务

[h3c]ftp server enable

4、登录服务器

>ftp 192.168.1.1

ftp>dir/ls(dir显示包括文件读写属性、大小、日期时间、文件名等属性,ls只显示文件名)

ftp>Get startup.cfg d:/sw1.cfg(将保存的配置文件从服务器上下载到本地机上,用记事本打开可以查看里面容)

说明:

上传文件:put

1) 将d:/sw1.cfg文件通过记事本修改(如:将sysname 改为zs)并保存

2) 上传文件Put d:/sw1.cfg startup.cfg(若上传后的文件名不是startup.cfg,则需要用设置下次启动时的配置文件,命令为:tartup saved-configuration filename)

3) 重新启动reboot,此时可以看到系统提示符为,说明修改的配置文件已经生效。

1、保证你的主机和目标设备网络可达,

2、在目标设备上开启ftp服务,并设置相应的用户名、密码、服务类型

3、直接在主机上命令行中运行ftp 目的主机地址(192.168.5.11),输入用户名和密码后,使用get命令获取你想要的文件

4、如果不知道那个是你的配置文件可以通过如下命令

dis start-up / dis saved-config(这个是保存的配置配件,命令好像是这样的,记得不是很清了)

或者直接在尖括号输入 dir

二、使用FTP方式

步骤1、在PC机“开始菜单”的“运行”栏中键入“cmd”,进入DOS界面,保证PC机可以PING通设备。

步骤2、在交换机上启动FTP服务器,并配置从PC机上FTP登陆时的用户名和密码

[H3C]ftp server enable /启动FTP服务/

% FTP server has been started

[H3C]local-user guest /增加一个本地用户,用户名为guest/

New local user added.

[H3C-luser-ftp]password simple ftp /配置用户名为guest的密码为ftp/

[H3C-luser-ftp]service-type ftp ftp-directory flash:/

/指定此用户的服务类型为ftp,且ftp后的上传下载目录为flash下/

步骤3、在PC机“开始菜单”的“运行”栏中键入“cmd”,进入DOS界面(1)获取配置文件

C:\>ftp 10.10.0.254

Connected to 10.10.0.254.

220 FTP service ready.

User (10.10.0.254:(none)): guest

331 Password required for guest.

Password:

230 User logged in.

ftp> dir

200 Port command okay.

150 Opening ASCII mode data connection for *.

-rwxrwxrwx 1 noone nogroup 5287115 Oct 31 2006 s5500si-cmw5

-rwxrwxrwx 1 noone nogroup 2254 May 05 04:05 config.cfg

226 Transfer complete.

ftp: 148 bytes received in 0.02Seconds 9.25Kbytes/sec.

ftp> get config.cfg

200 Port command okay.

150 Opening ASCII mode data connection for config.cfg.

226 Transfer complete.

ftp: 2254 bytes received in 0.00Seconds 2254000.00Kbytes/sec.

【提示】

1、此时在PC机的C:\文件夹下就可以看到备份的config.cfg文件了,可以通过记事本或写字板打开

(2)上传配置文件

# 以FTP方式登录FTP服务器,上传.bin文件,并存放于FTP服务器的根目录下。

c:\> ftp 10.10.0.254

ftp> put aaa.bin bbb.bin

远程用户——-internet——-F100 采用l2tp方式 sysname XXXX //设备名称

#

l2tp enable //开启l2tp功能

#

firewall packet-filter enable

firewall packet-filter default permit

#

undo connection-limit enable

connection-limit default deny

connection-limit default amount upper-limit 50 lower-limit 20

#

firewall statistic system enable

#

radius scheme system

server-type extended

#

domain system

ip pool 1 192.1.2.2 192.1.2.10

#

local-user admin

password cipher .]USE=B,53Q=^Q`MAF4<1!!

service-type telnet terminal

level 3

local-user xxx //配置拨号用户

password simple 123456

service-type ppp

interface Virtual-Template1 //配置虚拟接口模板1及其验证方式ppp authentication-mode pap

ip address 192.168.2.1 255.255.255.0

remote address pool 1

#

interface Ethernet1/0

ip address 172.16.2.2 255.255.255.252

#

interface Ethernet2/0

speed 10

duplex half

ip address 60.6.3.136 255.255.255.0

#

interface NULL0

#

firewall zone local

set priority 100

#

firewall zone trust //把虚拟接口模板添加进入安全域

add interface Ethernet1/0

add interface Virtual-Template1

set priority 85

#

firewall zone untrust

add interface Ethernet2/0

set priority 5

#

firewall zone DMZ

set priority 50

#

firewall interzone local trust

#

firewall interzone local untrust

#

firewall interzone local DMZ

#

firewall interzone trust untrust

#

firewall interzone trust DMZ

#

firewall interzone DMZ untrust

#

l2tp-group 1 //配置l2tp组1

undo tunnel authentication //取消隧道验证

allow l2tp virtual-template 1 //配置使用名字的方式发起l2tp连接#

FTP server enable

#

telnet source-interface Ethernet1/0

#

undo dhcp enable

#

ip route-static 0.0.0.0 0.0.0.0 60.6.3.1 preference 60 //配置静态默认路由

ip route-static 192.1.100.0 255.255.255.0 172.16.2.1 preference 60 //配置到网静态路由

ip route-static 192.2.100.0 255.255.255.0 172.16.2.1 preference 60 //配置到网静态路由

#

user-interface con 0

user-interface vty 0 4

authentication-mode scheme

#

return

windows L2TP客户端配置(以XP为例)

配置L2TP 拨号连接:

7、输入准备连接的L2TP 服务器的IP 地址“60.6.3.136”,单击“下一步”

8、单击“完成”。

9、双击“l2tp”连接,在l2tp 连接窗口,单击“属性”。

10、选择“安全”属性页,选择“高级(自定义设置)”,单击“设置”。

11、在“数据加密”中选择“可选加密(没有加密也可以连接)”。

12、在“允许这些协议”选中“不加密的密码(PAP)”、“质询握手身份验证协议(CHAP)”、“Microsoft CHAP(MS-CHAP)”,单击“确定”。

13、选择“网络”属性页面,在“VPN 类型”选择“L2TP IPSec VPN”。

14、选中“Internet 协议(TCP/IP)”

15、“NWLink IPX/SPX/NetBIOS Compatible Transport Prococol”、

“微软网络文件和打印共享”、

“微软网络客户”协议不选。

16、单击“确定”,保存所做的修改。

2. 修改注册表

缺省的Windows XP L2TP 传输策略不允许L2TP 传输不使用IPSec 加密。可以通过修改Windows XP 注册表来禁用缺省的行为:

通过附件自动修改

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters] "ProhibitIPSec"=dword:00000001

=============================================

//允许外网UDP数据访问192.168.0.1

nat server protocol udp global 1.1.1.1 any inside 192.168.0.1 any

ip address 1.1.1.1 255.0.0.0

宁可累死在路上,也不能闲死在家里!宁可去碰壁,也不能面壁。是狼就要练好牙,是羊就要练好腿。什么是奋斗?奋斗就是每天很难,可一年一年却越来越容易。不奋斗就是每天都很容易,可一年一年越来越难。能干的人,不在情绪上计较,只在做事上认真;无能的人!不在做事上认真,只在情绪上计较。拼一个春夏秋冬!赢一个无悔人生!早安!—————献给所有努力的人

相关文档