网络工程技能训练项目任务书

2014年网络工程技能训练项目任务书

一、项目行业、技术标准

网络工程在设计、建网、用网、管网过程中主要有以下5项国家标准,实施项目中要求遵循如下规范:

网络工程技能训练项目任务书

二、项目环境

场地包括11-108,11-308等两个标准网络工程实验室。环境依据需求和特点设计。环境标准要求、照明和通风良好;提供稳定的水、电,并提供应急的备用电源;提供一个灭火器和垃圾箱。

1.硬件设备

网络工程技能训练项目任务书

2.软件环境

网络工程技能训练项目任务书

3.材料清单

网络工程技能训练项目任务书

二、项目说明

1.注意事项:

(1)请按照以下环境,检查项目中使用硬件设备、网线和Console线等设备、材料和软件是否齐全,计算机设备是否能正常使用。

(2)操作过程中,需要及时保存设备配置。实训过程中,不要关闭任何设备,不要拆、动硬件连接。

(3)仔细阅读任务书,分析网络需求,按照任务书要求,进行设备配置和调试,若第二、三部分中提及的路径不存在,须学生按要求创建。

(4)项目训练时间为1周。

2.项目内容:

1)综合布线及耗材--视频教学

网络工程技能训练项目任务书

2)项目指标体系--知识与技能点

网络工程技能训练项目任务书

网络工程技能训练项目任务书

三、网络功能描述

网络工程技能训练项目任务书

图1 某公司网络拓扑结构图

某企业的网络拓朴如图1 所示,总公司网络中使用了两台三层交换机Switch-A 和Switch-B 提供内部网络的互联,使用一台二层交换机Switch-A作为服务器的接入,网络边缘采用一台路由器Router-A用于连接到分公司,总公司网络运行的是动态路由协议OSPF;总公司路由器与分公司路由器Router-B 点对点连接,并且封装的是PPP 协议,为了安全考虑两台路由器需要使用CHAP 验证机制。所有设备之间连接拓扑如图1,各设备连接接口及接口地址规划如表1 所示。题目中未说明的密码均设置为123。

四、配置要求

1.组网及网络设备配置

基本要求:

(1)正确制作10根网线并按拓朴图要求将设备正确连接。

(2)根据拓扑图命名交换机和路由器名称。

(3)按要求连接设备并正确配置路由器和交换机的接口IP。

技术要求:

1)三层路由:

1.合理的部署网络设备、PC和服务器的IP地址(见附表)

2.主公司内网用OSPF实现网络的互通,网络的出口使用默认路由实现内网所有节点都可以访问internet.

3.主公司通过三层交换机实现不同vlan间的通信。

说明:①OSPF使用process ID:1。

②OSPF的network语句使用基于接口网段的通告

③所有服务器属于vlan30。PC1属于vlan10,PC3属于vlan20。

④两台三层交换机均部署相同的SVI。

2)二层部署:

4.内网所有交换区块均开启802.1w的生成树协议(RSTP),设置Switch-A为生成树的根桥。

5.二层交换机和三层交换机之间的互联链路启用端口聚合,实现链路带宽的提升。

6.RA连接RB的serial口链路使用ppp封装,并启用chap。

说明:①通过设置Switch-A的优先级为4096的方式实现根桥选举。

②所有trunk口都启用基于802.1Q的中继封装协议。

③链路聚合启用基于lacp模式下的active模式,在聚合的接口下开启trunk。

④chap是同双向认证方式。对于 RA:.username Router-B password

123;RB.:username Router-A

password 123;

安全管理:

7.在两台二层交换机上部署端口安全实现:

?最大连接数量为:1;

?违例的惩罚措施:把接口置为error disable状态

?对于两台服务器使用mac地址绑定确保服务器的安全

8.通过ACL 100限制公司内部vlan10和vlan20所有PC所在网段到所有服务器的访问。(在SW-B上部署在vlan30出站调用)

9.使用PAT实现内网到外网的地址访问(基于端口映射,中间调用ACL 10),使用静态的NAT把对应的服务器的web服务发布到internet。

10.为所有网络设备部署telnet服务方面管理员管理网络设备

11.想办法实现分公司可以访问总公司linux-ser上的web服务。

说明:①enable的密码设置为:ruijie。

②telnet使用线下密码认证的方式实现,密码为123。

③Switch-C和Swich-B不要部署telnet(也可以所谓拓展尝试,提示必须三层可

达才可telnet)

④分公司可以访问总公司linux-ser上的web服务,在web界面下URL为

http://210.29.152.10:80

附表:设备接口及地址命名一览表

网络工程技能训练项目任务书

2.网络应用——Linux服务器配置

1)安装Linux服务器

在Linux-Ser上安装Linux系统(语言:简体中文),作为公司的资源共享服务器,要求如下:

(1)创建名称为Linux-Ser虚拟机,硬盘空间为50G,分配内存为512M,网卡使用桥接模式。

(2)根据要求配置服务器的IP地址等相关信息。

(3)设置root用户密码为123456,将Linux系统启动方式设置为文本方式。

2)DNS服务器配置

在Linux服务器上配置为DNS服务,为Internet用户提供域名解析。

(1)成功安装DNS组件包

(2)实现www. http://www.360docs.net/doc/info-5029077bb9d528ea80c77967.html、t. http://www.360docs.net/doc/info-5029077bb9d528ea80c77967.html和ftp. http://www.360docs.net/doc/info-5029077bb9d528ea80c77967.html三个域名的正反双向域名解析服务。

(3)配置DNS服务在图形界面随机启动。

3)telnet 配置

(1)成功安装telnet组件包

(2)配置好telnet服务,使用root、wlgc两个用户能远程登录linux server

(3)配置telnet服务在图形界面、字符界面随机启动。

4)samba服务器配置

(1)成功安装samba服务组件包

(2)samba服务配置要求如下:

PC2能通过网上邻居访问samba服务器,用户名为:wlgc,所属组为wlgc,用户只能登录samba服务器,不能登录linux系统,密码统一设置为123456,创建两个共享目录,/user/soft/wlgc,所有用户都有读写权限,/usr/soft/wlgc1只有wlgc用户有读写的权限,其它用户无任何权限。将创建的目录所有者从原来的root改为wlgc,并所属wlgc (3)配置samba服务在图形界面、字符界面随机启动。

3.网络应用——Windows服务器配置

1)在server1上安装Windows Server 2003服务器

(1)创建名称为Win-Ser的虚拟机,硬盘空间为50G,分配内存为512M,网卡使用桥接模式。

(2)将服务器名称改为Windows-Server。

(3)根据要求配置服务器的IP地址等相关信息。

(4)新建一个用户名为admin密码为wlgc@admin的系统管理员账户。

2)搭建域服务器

(1)服务器角色配置

配置Win-Ser为域控制器,其域名为http://www.360docs.net/doc/info-5029077bb9d528ea80c77967.html,域的功能级别为2003模式;(2)server01用户和组配置

创建2个OU,创建2 个全局组,创建6个用户,具体内容见下表:

网络工程技能训练项目任务书

3)WEB服务器配置

X公司刚开发了一个电子商务网站,公司需要搭建一个WEB服务器。

(1)请安装IIS组件,利用IIS6.0来建立WEB站点,站点主目录为c:\ wlgc;

(2)将会话超时时间设置为2分钟。

(3)日志文件记录到c:\inetpub\wwwroot\LogFiles目录下。

(4)设置主机头为www. http://www.360docs.net/doc/info-5029077bb9d528ea80c77967.html。

(5)在站点主目录下创建一个名为index.html内容为“网站正在建设中!”的网页文件并将其设置为默认主页。

4)打印机共享

(1)在服务器上安装好打印机并设置为共享

(2)让总公司用户PC1能正常使用网络打印机

五.项目其它要求

1.实训方式及要求

1)在网络工程进行实训,实训前由辅导老师讲清实训的目的、方法及要求;2)实训前学生应熟悉相应的理论知识;

3)可按照小组形式分组进行实训,一个小组2名学生。

2.实训考核形式及要求

1)实训后每小组交一份实训报告,要求实训的体会详实。

2)每小组交一个网络规划方案。

3)考核方法:实训报告+网络规划方案+过程表现。

4)最后根据答辩学生回答问题、设计表现的成绩记录等综合得出总成绩。六.成绩评定标准

网络工程技能训练项目任务书

网络工程技能训练项目任务书

七.实验室批次安排及分组名单1.实验室批次安排

网络工程技能训练项目任务书

网络工程技能训练项目任务书

2.分组名单

网络工程技能训练项目任务书

网络工程技能训练项目任务书

网络工程技能训练项目任务书

网络工程技能训练项目任务书

网络工程技能训练项目任务书

网络工程技能训练项目任务书

八.实验注意点

1.思科和锐捷命令去有区别之处(Cisco Packet Tracer和真机命令不同之处)

1)关于端口聚合(二层)

A.Cisco:(cisco叫Ether-channel,会继承物理接口属性因此聚合接口不用启用

trunk)

interface range FastEthernet0/23-24

channel-group 1 mode active

switchport trunk encapsulation dot1q(三层交换机需要这条命令)

switchport mode trunk

interface Port-channel 1

switchport trunk encapsulation dot1q(可选命令,PT计分软件此命令计分)switchport mode trunk

B.锐捷:(cisco叫端口聚合,不会继承物理接口属性因次聚合接口一定要启用

trunk)

interface range FastEthernet0/23 - FastEthernet0/24

port-group 3

interface Port-channel 1

switchport trunk encapsulation dot1q(三层交换机需要这条命令)

switchport mode trunk

注释:当然锐捷这种方案并不是传统意义上的LACP。

2)关于生成树

A.Cisco:(又叫PVSTP或者PVRSTP:一个vlan对应一个生成树域)

spanning-tree mode rapid-pvst

spanning-tree vlan 1,10,20,30 priority 4096

B.锐捷:(又叫CST:基于802.1w所有vlan对应一个生成树域)

spanning-tree

spanning-tree mode rstp

spanning-tree priority 4096

注释:IEEE定义的了802.1d STP

802.1w RSTP

802.1s MSTP

2.实验中的注意事项

A.三层路由注意点:

1)OSPF在三层交换机上通告的时候务必要把SVI口通告进来。

边界路由器

A.向内网下放缺省路由法二:

部署指向外网的缺省路由,并且在OSPF进程下部署default-information originate

B.向内网下放缺省路由法二:

无需部署缺省路由,直接输入default-information originate always

注意点:对于锐捷低端路由器第二种方案经常出BUG因此不建议使用

相关文档