华为 eSpace 统一通信解决方案 V2.3 协议顺从表
U1981/U1960/ U1911 √ √ √(透传) √ √ × √ √ √ √ √
×
Opus
IETF
×
H.624
ITU-T
T.120 RFC 0768 RFC 0791 RFC 0792 RFC 0793 RFC 0959 RFC 1035 RFC1889 RFC1890 RFC 1904 RFC 2198 RFC 2327 RFC 2396 RFC 2475 RFC 2543 RFC 2597 RFC 2598 RFC 2616 RFC 2617 RFC 2782 RFC 2806 RFC 2833 RFC 2976 RFC 3047
IETF IETF IETF IETF
Session Initiation Protocol Reliability Of Provisional Responses in the Session Initiation Protocol (SIP) Session Initiation Protocol (SIP): Locating SIP Servers An Offer/Answer Model with the Session Description Protocol (SDP): Howto: SIP Reverse negociation - Call Transfer SIP Locating SIP Servers RTP Payload and File Storage Format for the AMR/AMR-WB(G.722.2) Codecs The Session Initiation Protocol(SIP) UPDATE method Integration of Resource Management and Session Initiation Protocol (SIP) (updated by RFC 4032) Private SIP Extensions for Media Authorization Name identification The Reason Header Field for the Session Initiation Protocol (SIP) Session Initiation Protocol (SIP) Extension Header Field for Registering Non-Adjacent Contacts RFC 3327 (Proposed Standard) Updated by RFC 5626 Grouping of Media Lines in the Session Description Protocol (SDP) RTP Payload for Comfort Noise Internet Media Type message/sipfrag Extension for Instant Messaging The Session Initiation Protocol (SIP) Refer Method RTP: Transport Protocol for Real-Time Applications RTP Profile for Audio and Video Conferences with Minimal Control MIME Type Registration of RTP Payload Formats Mapping of Integrated Services Digital Network (ISDN) User Part (ISUP) Overlap Signalling to the Session Initiation Protocol (SIP) An Extension to the Session Initiation Protocol (SIP) for Symmetric Response Routing RTP Control Protocol Extended Reports (RTCP XR) SIP Event Package for Registrations
U1900系列网关 标准 Q.921 Q.931 T.30 T.38 G.711 G.723.1 G.729 G.722 G.722.1(Sir en7) G.722.2 (AMR-WB) iLBC
发布组织
ITU-T ITU-T ITU-T ITU-T ITU-T ITU-T ITU-T ITU-T ITU-T ITU-T IETF
RFC 3261 RFC 3262 RFC 3263 RFC 3264 RFC 3265 RFC 3267 RFC 3311 RFC 3312 RFC 3313 RFC 3325 RFC 3326 RFC 3327 RFC 3388 RFC 3389 RFC 3420 RFC 3428 RFC 3515 RFC 3550 RFC 3551 RFC 3555 RFC 3578 RFC 3581 RFC3611 RFC 3680 RFC 3711 RFC 3764 RFC 3824 RFC 3842 RFC 3853 RFC 3856 RFC 3863 RFC 3891 RFC 3892 RFC 3903 RFC 3952 RFC 3959 RFC 3960 RFC 4028 RFC4217 RFC 4235 RFC4240
√ √ √ √ √ √ √ × × √ √ ×
IETF IETF IETF IETF IETF IETF IETF
√ √ √ × √ √ × × × × × √ √ × × √ × × × √ × √ √ √ √ √ √ ×
ITU-T IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF IETF
ቤተ መጻሕፍቲ ባይዱ
× √ √ √ √ × × √ × × √ √ √ × √ √ √ √ √ × × √ √ √
描述 ISDN user-network interface - Data link layer specification ISDN user-network interface layer 3 specification for basic call control Procedures for document facsimile transmission in the general switched telephone network - Corrigendum 1 T.38 is an ITU standard for sending FAX accross IP networks in a real-time mode. FAX messages are sent as UDP or TCP/IP packets. Pulse code modulation (PCM) of voice frequencies Dual rate speech coder for multimedia communications transmitting at 5.3 and 6.3 kbit/s Coding of speech at 8 kbit/s using conjugate-structure algebraic-codeexcited linear-prediction 7 kHz Wideband audio codec operating at 48, 56 and 64 kbit/s. based on Siren codecs and offers lower bit-rate compressions (24 kbit/s or 32 kbit/s) based on ACELP and offers even lower bit-rate compressions (6.6 kbit/s to 23.85 kbit/s) Short for Internet Low Bit Rate Codec .It is designed for narrow band speech and results in apayload bit rate of 13.33 kbit/s for 30 ms frames and 15.20 kbit/s for 20 ms frames. A lossy audio compression format developed by the IETF, can be adjusted seamlessly between high and low bitrates, that is particularly suitable for interactive real-time applications over the Internet. H.264 is a standard for high-definition video recording, compression, and distribution. The ITU-T H.264 standard and the ISO/IEC MPEG-4 AVC standard are jointly maintained so that they have identical technical contents Data protocols for multimedia conferencing User Datagram Protocol (UDP) Internet Protocol (IP) Internet Control Message Protocol (ICMP) Transfer Control Protocol (TCP) File Transfer Protocol (FTP) Domain Names Implementation and Specification RTP: A Transport Protocol for Real-Time Applications RTP Profile for Audio and Video Conferences with Minimal Control NFS: Network File System Protocol Specification RTP Payload for Redundant Audio Data SDP: Session Description Protocol Uniform Resource Identifiers (URI): Generic Syntax An Architecture for Differentiated Services SIP: Session Initiation Protocol Assured Forwarding PHB Group; An Expedited Forwarding PHB Hypertext Transfer Protocol -- HTTP/1.1 HTTP Authentication: Basic and Digest Access Authentication A DNS RR for specifying the location of services (DNS SRV) URLs for Telephone Calls RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals The SIP INFO method RTP Payload Format for ITU-T Recommendation G.722.1
02-H320与H323协议体系介绍
2.
6.ARQ
1.ARQ
LRQ 定位请求,通过GK路由前缀,向 邻居GK查询 075501的IP LCF 定位确认 075501(192.168.0.2) ACF 呼叫确认 01001 (192.168.0.1)075502 (192.168.0.2), 384K
3. 4.
7.ACF
4.ACF
5.SETUP
呼叫过程中的信令处理 。 H.245多媒体控制信令——主/被叫节点之间进行信息交互所使用的协议 。
H.235 ---- 通信加密协议
H.239 ---- 基于令牌的多流传输协议 视音频协议——H.261、H.263、H.264、G.7XX、AAC_LD等
实时传输协议(RTP/RTCP)
Page 23
2.2 点对点呼叫信令流程-打开逻辑通道
HUAWEI TECHNOLOGIES CO., LTD.
华为保密信息,未经授权禁止扩散
Page 24
2.2 点对点呼叫信令流程-不同GK下的点对点呼叫
2.LRQ
1.
GK2
0755
ARQ
呼叫请求 01001 075501
GK1
010
3.LCF
H.323协议基础 会议调度信令流程 华为H.323 E1/4E1组网方式 H.320协议介绍
HUAWEI TECHNOLOGIES CO., LTD.
华为保密信息,未经授权禁止扩散
Page 18
第 2章
2.1 2.2 2.3
会议调度信令流程
注册信令流程 点对点呼叫信令流程 MCU调度信令流程
HUAWEI TECHNOLOGIES CO., LTD.
GK
1.ARQ
2.2 USM系统介绍
Copyright © 2012 Huawei Technologies Co., Ltd. All rights reserved.
Page 3
Page3
目录
第1节 USM组网原理部署
Copyright © 2012 Huawei Technologies Co., Ltd. All rights reserved.
U1900
U1900
电话
传真机
IP电话
IP电话
电话
Page 6
传真机
Copyright © 2012 Huawei Technologies Co., Ltd. All rights reserved.
USM部署方案
1万 4万
(OMU与USM合设)*1 OMU*1+USM*1 OMU*1+USM*3 OMU*1+USM*4 OMU*1+USM*7
通用服务器2
Page 11
双机部署 – 分设(10万用户容量)
USM IFM进程
OMU IFM进程 数据库 OS(Linux) 数据库 OS(Linux) SPG 2 SPG 2
USM
CDB进 程 SPG 3
USM
CCU进程 CCU进程 BSG进程 BSG进程
SPG 4
SPG4
数据库 OS(Linux)
Copyright © 2012 Huawei Technologies Co., Ltd. All rights reserved.
Page 18
预安装场景 - 检查磁盘划分
分区 / swap /boot /usr /var /tmp 空间大小(GB) 25 4 1 10 5 10 文件系统类型 ext3 swap ext3 ext3 ext3 ext3 分区类型 主分区 主分区 主分区 扩展分区 扩展分区 扩展分区
华为USG2000&5000统一安全网关配置报价操作指导手册
Huawei Confidential
Page 4
USG5500系列板卡支持清单
项目
固定接口 扩展插槽 USB卡 USB-WCDMA 3G USB-CDMA2000 3G USB-TD-SCDMA 3G MIC接口卡 DMIC-2*10G(SFP+) FIC接口卡 FIC-8*GE电 FIC-8*GE光 FIC-2*10G(SFP+) FIC-2*10G(SFP+)+8GE电 FIC-4GE电BYPASS(2路) FIC-GE光BYPASS(2路) DFIC接口卡 DFIC-18FE+2SFP DFIC-16GE+4SFP
产品名称 USG2110-x USG2130 USG2160 USG2210 USG2220 USG2230 USG2250 USG5120 USG5150 USG5160 USG5530S USG5530 USG5550 USG5560
标配接口 2FE+8FE 1FE+8FE 1FE+8FE 2GE combo 2GE combo 2GE combo 2GE combo 2GE+2GE combo 4GE combo 4GE combo 4GE+4GE combo 4GE+4GE combo 4GE+4GE combo 4GE+8GE光+4GE combo
● ● ●
●
● ● ● ● ● ●
● ●
HUAWEI TECHNOLOGIES CO., LTD.
Huawei Confidential
Page 5
Huawei Enterprise A Better Way
Copyright© 2012 Huawei Technologies Co., Ltd. All Rights Reserved. The information in this document may contain predictive statements including, without limitation, statements regarding the future financial and operating results, future product portfolio, new technology, etc. There are a number of factors that could cause actual results and developments to differ materially from those expressed or implied in the predictive statements. Therefore, such information is provided for reference purpose only and constitutes neither an offer nor an acceptance. Huawei may change the information at any time without notice.
宇电AIBUS及MODBUS通讯协议说明V80
宇电AIBUS及MODBUS通讯协议说明(V8.0)AIBUS是厦门宇电自动化科技有限公司为AI系列显示控制仪表开发的通讯协议,能用简单的指令实现全面的功能,其特点是写参数的同时亦可完成读功能,因此写参数时不破坏读的循环周期时间,加上指令长度较少,因此具有比MODBUS更快的速率(尤其是有写入指令时,MODBUS的写入指令不能同时完成读下位机数据的功能,会破坏读指令的周期,延长了读的循环周期),AIBUS协议具有组建大规模过程控制系统能力。
AIBUS采用了16位的求和校正码,下位机运算快速且通讯可靠,支持9600和19200等不同波特率,在19200波特率下,上位机访问一台AI-7/8系列高性能仪表的平均时间仅20mS,访问AI-5系列仪表的平均时间为40mS。
仪表允许在一个RS485通讯接口上连接多达80台仪表(为保证通讯可靠,仪表数量大于60台时需要加一个RS485中继器)。
AI系列仪表可以用PC、触摸屏及PLC作为上位机,其软件资源丰富,发展速度极快。
基与PC的上位机软件广泛采用WINDOWS作为操作环境,不仅操作直观方便,而且功能强大。
最新的工业平板触摸屏式PC的应用,更为工业自动化带来新的界面。
这使得采用仪表+上位机结构的测控系统价格大大低于传统DCS系统,而性能及可靠性也具备比传统DCS系统更优越的潜力。
宇电AI-5系列仪表写入寿命可达100万次,而AI-7/8系列仪表则允许连续写参数,如写给定值或输出值,写入寿命高达10亿次,可利用上位机将仪表组成复杂调节系统。
一、接口规格AI系列仪表使用异步串行通讯接口,接口电平符合RS232C或RS485标准中的规定。
数据格式为1个起始位,8位数据,无校验位,1个或2个停止位。
通讯传输数据的波特率可调为4800~19200 bit/S,通常用9600 bit/S,单一通讯口所连接仪表数量大于40台或需要更快刷新率时,推荐用19200bit/S,当通讯距离很长或通讯不可靠常中断时,可选4800bit/S。
华为公司宽带产品Portal协议标准
Q/DKBA华为技术有限公司企业技术标准Q/DKBAXXXX-2001华为公司宽带产品Portal协议标准第2部分:Portal标准V2.012001-XX-XX发布2001-XX-XX实施华为技术有限公司发布修订说明本文档对2.0版本做了如下修改:1.增加了WEB_STATUS_NOTIFY和WEB_ACK_STATUS_NOTIFY命令字2.修改ReqID字段的说明3.修改Port字段的说明4.附录增加成功上线的报文示例目录1 范围 52 术语和定义 53 概述 54 协议 54.1 报文格式 54.2 报文字段说明 64.2.1 Ver 64.2.2 Type 64.2.3 Pap/Chap 74.2.4 Rsv 74.2.5 SerialNo 74.2.6 ReqID 84.2.7 UserIP 84.2.8 UserPort 84.2.9 ErrCode 84.2.10 AttrNum 94.2.11 Authenticator 94.2.12 报文属性字段(Attr)的格式105 流程和相关说明145.1 Chap认证方式上线流程145.2 Pap认证方式上线流程175.3 下线流程195.4 信息询问流程(无论成功还是失败)205.4 下线通知流程(BAS通知Portal Server)226 其他说明236.1 关于TextInfo属性的使用236.2 协议的兼容性236.3 协议的不完善之处236.4 协议其他说明237 附录237.1 成功的Chap认证报文示例237.2 成功的Pap认证报文示例25前言本标准由宽带联合系统部提出。
本标准主要起草部门:宽带联合系统部,MA5200产品组,ESR产品组,iNet产品组本标准主要解释部门:宽带总体组本标准主要起草人:杨宏杰、周和秘、乔明本标准主要审核人:卢朝晖、胡鹏本标准修改人:李建军、徐亦斌华为公司宽带产品Portal协议标准V2.011范围本标准规定了华为公司宽带产品所采用的Portal协议标准。
华为 FusionServer Pro 2288H V5 服务器 用户指南说明书
FusionServer Pro 2288H V5 服务器V100R005用户指南文档版本08发布日期2019-10-30版权所有 © 华为技术有限公司 2019。
保留一切权利。
非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。
商标声明和其他华为商标均为华为技术有限公司的商标。
本文档提及的其他所有商标或注册商标,由各自的所有人拥有。
注意您购买的产品、服务或特性等应受华为公司商业合同和条款的约束,本文档中描述的全部或部分产品、服务或特性可能不在您的购买或使用范围之内。
除非合同另有约定,华为公司对本文档内容不做任何明示或默示的声明或保证。
由于产品版本升级或其他原因,本文档内容会不定期进行更新。
除非另有约定,本文档仅作为使用指导,本文档中的所有陈述、信息和建议不构成任何明示或暗示的担保。
华为技术有限公司地址:深圳市龙岗区坂田华为总部办公楼邮编:518129网址:https://前言概述本文档介绍2288H V5的产品外观、功能、结构、安装和拆卸、基本配置、操作系统的安装方法、部件更换及故障处理。
读者对象本文档主要适用于以下工程师:l企业管理员l企业终端用户符号约定在本文中可能出现下列标志,它们所代表的含义如下。
修改记录目录前言 (ii)1 简介 (1)1.1 产品概述 (1)1.2 物理结构 (2)1.3 逻辑结构 (3)2 硬件描述 (5)2.1 前面板 (5)2.1.1 外观 (5)2.1.2 指示灯和按钮 (7)2.1.3 接口 (11)2.2 后面板 (13)2.2.1 外观 (13)2.2.2 指示灯 (14)2.2.3 接口 (16)2.3 处理器 (18)2.4 内存 (19)2.4.1 内存标识 (19)2.4.2 内存子系统体系结构 (20)2.4.3 内存兼容性信息 (21)2.4.4 内存安装准则 (23)2.4.5 内存插槽位置 (23)2.4.6 内存保护技术 (25)2.5 存储 (25)2.5.1 硬盘配置 (26)2.5.2 硬盘编号 (29)2.5.3 硬盘指示灯 (33)2.5.4 RAID控制卡 (35)2.6 网络 (35)2.6.1 灵活IO卡 (35)2.7 IO扩展 (38)2.7.1 PCIe卡 (38)2.7.2 PCIe插槽 (38)2.7.3 PCIe插槽说明 (42)2.8 电源 (47)2.9 风扇 (48)2.10 单板 (49)2.10.1 主板 (50)2.10.2 硬盘背板 (52)3 产品规格 (57)3.1 技术规格 (57)3.2 环境规格 (62)3.3 物理规格 (63)4 软硬件兼容性 (65)5 管制信息 (66)5.1 安全 (66)5.2 维保与保修 (69)6 静电释放 (70)6.1 防止静电释放 (70)6.2 防止静电释放的接地方法 (70)7 安装与配置 (72)7.1 安装环境要求 (72)7.1.1 空间与通风要求 (72)7.1.2 温度与湿度要求 (73)7.1.3 机柜要求 (73)7.2 安装硬件 (73)7.2.1 安装简介 (74)7.2.2 拆卸服务器外包装 (74)7.2.3 安装硬件选件 (75)7.2.4 安装服务器导轨 (75)7.2.4.1 安装L型滑道 (75)7.2.4.2 安装可伸缩滑道 (77)7.2.4.3 安装抱轨 (78)7.2.5 安装服务器 (79)7.2.5.1 L型滑道/可伸缩滑道上安装服务器 (79)7.2.5.2 抱轨上安装服务器 (80)7.2.6 安装外部线缆 (83)7.2.6.1 布线指导 (84)7.2.6.2 安装鼠标、键盘和VGA接口线缆 (84)7.2.6.3 安装网线 (85)7.2.6.4 安装光口线缆 (87)7.2.6.5 安装IB线缆 (89)7.2.6.6 安装外置USB设备 (91)7.2.6.7 安装串口线缆 (92)7.2.6.8 安装电源模块线缆 (93)7.2.6.8.1 安装交流电源模块线缆 (93)7.2.6.8.2 安装直流电源模块线缆 (94)7.2.6.9 检查线缆连接 (95)7.3 上电与下电 (96)7.3.1 上电 (96)7.3.2 下电 (97)7.4 初始配置 (98)7.4.1 默认数据 (98)7.4.2 配置简介 (99)7.4.3 修改初始密码 (100)7.4.3.1 修改iBMC默认用户的初始密码 (100)7.4.3.2 修改iBMC U-Boot的初始密码 (102)7.4.4 检查服务器 (103)7.4.5 配置iBMC IP地址 (105)7.4.6 配置RAID (106)7.4.7 配置BIOS (106)7.4.7.1 进入BIOS系统 (107)7.4.7.2 设置系统启动顺序 (107)7.4.7.3 设置网卡PXE (108)7.4.7.4 设置BIOS密码 (109)7.4.7.5 切换界面语言 (109)7.4.7.6 重启服务器 (110)7.4.8 安装操作系统 (110)7.4.9 使系统保持最新状态 (111)8 故障处理指导 (112)9 常用操作 (113)9.1 查询iBMC管理网口的IP地址 (113)9.2 登录iBMC WebUI (114)9.3 登录服务器实时桌面 (117)9.3.1 通过远程虚拟控制台登录 (117)9.3.1.1 iBMC (117)9.3.2 通过独立远程控制台登录 (120)9.3.2.1 Windows (120)9.3.2.2 Ubuntu (122)9.3.2.3 MAC (124)9.4 登录服务器命令行 (126)9.4.1 通过PuTTY登录(网口方式) (127)9.4.2 通过PuTTY登录(串口方式) (128)9.5 管理VMD功能 (130)9.5.1 开启VMD功能 (131)9.5.2 关闭VMD功能 (131)9.6 进入BIOS系统 (132)9.6.1 进入BIOS系统(Skylake) (132)9.6.2 进入BIOS系统(Cascade Lake) (133)9.7 清除存储介质数据 (135)10 更多资源 (138)10.1 获取技术支持 (138)10.2 产品信息资源 (139)10.3 产品配置资源 (139)10.4 维护工具 (140)11 软件和配置实用程序 (141)11.1 iBMC (141)11.2 BIOS (142)11.3 FusionServer Tools SmartKit (142)A 附录 (145)A.1 术语 (145)A.1.1 A-E (145)A.1.2 F-J (145)A.1.3 K-O (146)A.1.4 P-T (146)A.1.5 U-Z (147)A.2 缩略语 (147)A.2.1 A-E (147)A.2.2 F-J (148)A.2.3 K-O (150)A.2.4 P-T (151)A.2.5 U-Z (153)A.3 产品序列号 (153)A.4 工作温度规格限制 (155)A.5 铭牌型号 (157)A.6 RAS特性 (157)A.7 传感器列表 (159)1简介1.1 产品概述1.2 物理结构1.3 逻辑结构1.1 产品概述华为FusionServer Pro 2288H V5(以下简称2288H V5)是华为公司针对互联网、IDC(Internet Data Center)、云计算、企业市场以及电信业务应用等需求,推出的具有广泛用途的新一代2U2路机架服务器。
华为LTE CPE eA280-204产品说明书
HUAWEI LTE CPE eA280-204 Product DescriptionIssue V1.2Date 2017-08-28Copyright © Huawei Technologies Co., Ltd. 2017. All rights reserved.No part of this document may be reproduced or transmitted in any form or by any means without prior written consent of Huawei Technologies Co., Ltd.Trademarks and Permissionsand other Huawei trademarks are trademarks of Huawei Technologies Co., Ltd.All other trademarks and trade names mentioned in this document are the property of their respective holders.NoticeThe purchased products, services and features are stipulated by the contract made between Huawei and the customer. All or part of the products, services and features described in this document may not be within the purchase scope or the usage scope. Unless otherwise specified in the contract, all statements, information, and recommendations in this document are provided "AS IS" without warranties, guarantees or representations of any kind, either express or implied.The information in this document is subject to change without notice. Every effort has been made in the preparation of this document to ensure accuracy of the contents, but all statements, information, and recommendations in this document do not constitute a warranty of any kind, express or implied.HUAWEI TECHNOLOGIES CO., LTD.Address:HQ of HuaweiBantian, Longgang District Shenzhen 518129 People's Republic of ChinaWebsite: Email:******************Product Description ContentsContents1 Overview (4)2 Application Scenarios (6)3 Technical Specifications (8)3.1 Hardware (8)3.2 Antenna (10)3.3 Software (10)3.4 Accessories and software (13)3.4.1 LTE antenna: (13)3.4.2 WiFi antenna: (13)3.4.3 Power Adapter: (13)3.4.4 Software version: (13)4 Services and Applications (14)5 Reference Standards (15)6 Packing List (16)7 Acronyms and Abbreviations (17)1 OverviewIntroductionHuawei eA280-204 CPE is the wireless gateway of LTE. The eA280-204 can be deployedindoors to provide services such as data collection and video surveillance. CPE is short forcustomer premises equipment.The eA280-204 supports 3GPP R11/R12. The eA280-204 provides the following functions:●Data service●V oice service●Security service●Local and remote maintenance and management●Data routingHighlightsThe eA280-204 supports the following specifications:●LTE Band 31(452.5~457.5MHz,462.5~467.5MHz)●1T2R configuration●Internal LTE antenna●WLAN 2.4 GHz (802.11b/g/n) for an internal Wi-Fi antenna●WPS 2.0●2x2 MIMO●LTE DL Category 6 and UL Category 5●Two Ethernet ports●V oIP services●Dynamic Host Configuration Protocol (DHCP) and Network Address Translation (NAT)●Routing Behind MS●VxLAN●L2VPN over GRE●L2TP●Two APNs (one for voice services and the other for data services)●UE direct connecting●Soft SIM cards●Frequency lock●Firewall●IE, Firefox, Chrome, and Safari●Management on the Web UI●Device management complying with TR-069●LED indicatorsExteriorFigure 1-1 shows the exterior of the eA280-204.Figure 1-1eA280-204 exterior2 Application Scenarios The eA280-204 is designed to provide users with wireless broadband data access services in the wISP market.The eA280-204 provides LTE wireless routing and exchanges data between LTE wireless networks and wired Ethernet networks.SOHO users can set up either wired or wireless connections to the eA280-204 to achievehigh-speed services.The eA280-204 allows 32 Wi-Fi devices (2.4 GHz) to provide wireless network connections and connects to hubs and switches to form a local area network (LAN).Figure 2-1eA280-204 connected to multiple devicesThe eA280-204 provides one port for connecting a telephone to perform basic voice services.Figure 2-2eA280-204 connected to a telephone3 Technical Specifications3.1 HardwareTable 3-1 lists the hardware specifications of the eA280-204.Table 3-1Hardware specificationsIt is recommended that the eA280-204 be deployed on the live network within three months after delivery or be stored in the following environment:●Temperature: –10°C to 35°C●Relative humidity: 30% RH to 85% RHThe storage environment should be equipped with temperature, humidity, and dehumidification devicesto monitor and adjust the temperature and humidity.3.2 AntennaTable 3-2Specifications of an internal LTE antennaTable 3-3Specifications of an internal Wi-Fi antenna3.3 SoftwareTable 3-4 lists the software specifications of the eA280-204.Table 3-4Software specifications3.4 Accessories and software3.4.1 LTE antenna:3.4.2 WiFi antenna:3.4.3 Power Adapter:3.4.4 Software version:eA280-204 software version is V100R001.Product Description 4 Services and Applications4 Services and ApplicationsData ServiceThe eA280-204 provides access to LTE wireless broadband networks with high-speed dataservices.Voice ServiceThe eA280-204 can provide high-quality V oIP services by connecting to a common telephone.It can also provide supplementary services enabled on the operator side, such as call waiting,call holding, and call transferring.Security ServiceThe eA280-204 provides firewall functions which enable users to protect their computerswhen accessing the Internet.FirewallThe following firewall functions are provided:●Firewall switch: Enable or disable the firewall.●LAN MAC address filtering: Prevent devices with specified MAC addresses on a LANfrom accessing the network.●LAN IP address filtering: Prevent devices with specified IP addresses from accessingcomputers on the LAN.●URL filtering: Prevent computers on the LAN from visiting specified URLs.Local Management and MaintenanceThe eA280-204 supports local configuration to manage devices, configure networkparameters, and help ensure that the device functions properly and stably.Remote Management and MaintenanceThe eA280-204 allows users to remotely manage connected devices complying with TR-069on the Web UI.Product Description 5 Reference Standards5 Reference StandardsCommunication StandardsTable 5-1 lists the communication standards that the eA280-204 complies with.Table 5-1eA280-204 communication standardsWireless Interface ProtocolsAs to the Uu interface, the eA280-204 complies with 3GPP R11/R12.Product Description 6 Packing List6 Packing ListTable 6-1 describes the packing list for the eA280-204.Table 6-1eA280-204 packing list7 Acronyms and Abbreviations This chapter lists the acronyms and abbreviations related to the eA280-204.Table 7-1Acronyms and abbreviations。
VoLTE基本网络架构和业务流程v1 0
Huawei Confidential
Page 7
目录
VoLTE注册流程 VoLTE基本会话流程 VoLTE短信流程
HUAWEI TECHNOLOGIES CO., LTD.
Huawei Confidential
Page 8
VoLTE注册流程(本省)
流程关键点:
Single SDB
• 4个注册过程:EPC注册->SGs联合附着->IMS注册->AS第三方注册;
地I-CSCF,拜访地I-CSCF寻址归属地S-CSCF的方式; • 目前由HSS上签约S-CSCF能力集的方式实现,需要在
拜访网络的I-CSCF上配置S-CSCF能力集对应的S-CSCF 域名/主机名;
HSS,采用HLR/EPS-HSS/IMS-HSS三 合一方案,存放2G/3G/4G和VoLTE用户 数据
O&M: CCF,EMS, SPG
L/HDRA进行Diameter信令互通,支持 Cx/Sh/Zh/Gx/Rx/S6a接口互通和寻址
MME/S/P-GW,将现网MME/S/P-GW 升级改造支持VoLTE业务
和SCC AS配合,提供SRVCC功能。 存储用户签约信息和位置信息的用户数据库系统。
功能描述
提供用户定位功能。当IMS网络存在多个HSS设备,并且各HSS设备保存的开户用户有差异时,IMS域内向HSS获取用户数据的网元 (I-CSCF/S-CSCF/AS)在查询HSS前先用SLF定位已开户用户数据存储在哪个HSS。
Single SDB
USCDB
MMtel AS/ SCC AS/IPSM-GW
流程关键点:
• 4个注册:拜访地(EPS注册->SGs联合附着)
eSpace UC2.0 安装_all in one V1.0
Page 6
2.1 安装流程
注:现场绝大多数场景是完全预安装场景,UC业务不需要安装,只需修改下IP信息就可 以使用了,该胶片主要讲手工安装UC业务的场景
Copyright © 2010 Huawei Technologies Co., Ltd. All rights reserved. Page 7
/opt/package /opt/package /opt/package/software/orac le
UC0COMPAC20VxxxRxxxCxx.rar 数据管理板 UC0BMPPAC20VxxxRxxxCxx.rar UC0MAAPAC20VxxxRxxxCxx.rar UC0MEETING20VxxxRxxxCxx.rar UC0SDS20VxxxRxxxCxx.rar UC0EMSPAC20VxxxRxxxCxx.rar •ORACLE11ENT01_111078_Linux-x86-64.part1.rar Copyright © 2010 Huawei Technologies Co., Ltd. All rights reserved. •ORACLE11ENT01_111078_Linux-x86-64.part2.rar
Conf_AudioMRSI P Conf_AudioMRSP ort
Conf_AccessCod 会议接入码。 e ChatServerPref 临时群号首。 ix ChatServerDoma 临时群域名。 in
ASServerIP
核心控制板的IP地址。
根据规划设置,例如10.166.37.134。
UC0COMPAC20VxxxRxxxCxx.rar UC业务板 UC0SNE20VxxxRxxxCxx.rar •ORACLE11ENT01_111078_Linux-x86-64.part1.rar •ORACLE11ENT01_111078_Linux-x86-64.part2.rar •ORACLE11ENT01_111078_Linux-x86-64.part3.rar
乐鑫信息科技 ESP32-C3 ESP-AT 用户指南 Release v2.3.0.0-esp32
ESP32-C3ESP-AT用户指南Release v2.3.0.0-esp32c3-182-g6e9756e7乐鑫信息科技2023年06月27日Table of contentsTable of contents i 1入门指南31.1ESP-AT是什么 (3)1.2硬件连接 (4)1.2.1硬件准备 (4)1.2.2ESP32-C3系列 (4)1.3下载指导 (5)1.3.1下载AT固件 (5)1.3.2烧录AT固件至设备 (7)1.3.3检查AT固件是否烧录成功 (9)2AT固件112.1发布的固件 (11)2.1.1ESP32-C3-MINI-1系列 (11)3AT命令集133.1基础AT命令 (13)3.1.1AT:测试AT启动 (13)3.1.2AT+RST:重启模块 (14)3.1.3AT+GMR:查看版本信息 (14)3.1.4AT+CMD:查询当前固件支持的所有命令及命令类型 (15)3.1.5AT+GSLP:进入Deep-sleep模式 (15)3.1.6ATE:开启或关闭AT回显功能 (16)3.1.7AT+RESTORE:恢复出厂设置 (16)3.1.8AT+UART_CUR:设置UART当前临时配置,不保存到flash (16)3.1.9AT+UART_DEF:设置UART默认配置,保存到flash (17)3.1.10AT+SLEEP:设置睡眠模式 (18)3.1.11AT+SYSRAM:查询当前剩余堆空间和最小堆空间 (20)3.1.12AT+SYSMSG:查询/设置系统提示信息 (20)3.1.13AT+SYSFLASH:查询或读写flash用户分区 (22)3.1.14AT+FS:文件系统操作 (23)3.1.15AT+RFPOWER:查询/设置RF TX Power (24)3.1.16说明 (25)3.1.17AT+SYSROLLBACK:回滚到以前的固件 (25)3.1.18AT+SYSTIMESTAMP:查询/设置本地时间戳 (25)3.1.19AT+SYSLOG:启用或禁用AT错误代码提示 (26)3.1.20AT+SLEEPWKCFG:设置Light-sleep唤醒源和唤醒GPIO (27)3.1.21AT+SYSSTORE:设置参数存储模式 (28)3.1.22AT+SYSREG:读写寄存器 (29)3.1.23AT+SYSTEMP:读取芯片内部摄氏温度值 (30)3.2Wi-Fi AT命令集 (30)3.2.1AT+CWMODE:查询/设置Wi-Fi模式(Station/SoftAP/Station+SoftAP) (31)3.2.2AT+CWSTATE:查询Wi-Fi状态和Wi-Fi信息 (32)3.2.3AT+CWJAP:连接AP (32)3.2.4AT+CWRECONNCFG:查询/设置Wi-Fi重连配置 (35)3.2.5AT+CWLAPOPT:设置AT+CWLAP命令扫描结果的属性 (36)i3.2.6AT+CWLAP:扫描当前可用的AP (37)3.2.7AT+CWQAP:断开与AP的连接 (38)3.2.8AT+CWSAP:配置ESP32-C3SoftAP参数 (38)3.2.9AT+CWLIF:查询连接到ESP32-C3SoftAP的station信息 (39)3.2.10AT+CWQIF:断开station与ESP32-C3SoftAP的连接 (40)3.2.11AT+CWDHCP:启用/禁用DHCP (40)3.2.12AT+CWDHCPS:查询/设置ESP32-C3SoftAP DHCP分配的IP地址范围 (42)3.2.13AT+CWAUTOCONN:上电是否自动连接AP (42)3.2.14AT+CWAPPROTO:查询/设置SoftAP模式下802.11b/g/n协议标准 (43)3.2.15AT+CWSTAPROTO:设置Station模式下802.11b/g/n协议标准 (44)3.2.16AT+CIPSTAMAC:查询/设置ESP32-C3Station的MAC地址 (44)3.2.17AT+CIPAPMAC:查询/设置ESP32-C3SoftAP的MAC地址 (45)3.2.18AT+CIPSTA:查询/设置ESP32-C3Station的IP地址 (46)3.2.19AT+CIPAP:查询/设置ESP32-C3SoftAP的IP地址 (47)3.2.20AT+CWSTARTSMART:开启SmartConfig (48)3.2.21AT+CWSTOPSMART:停止SmartConfig (49)3.2.22AT+WPS:设置WPS功能 (50)3.2.23AT+MDNS:设置mDNS功能 (51)3.2.24AT+CWJEAP:连接WPA2企业版AP (51)3.2.25AT+CWHOSTNAME:查询/设置ESP32-C3Station的主机名称 (53)3.2.26AT+CWCOUNTRY:查询/设置Wi-Fi国家代码 (54)3.3TCP/IP AT命令 (55)3.3.1AT+CIPV6:启用/禁用IPv6网络(IPv6) (56)3.3.2AT+CIPSTATE:查询TCP/UDP/SSL连接信息 (56)3.3.3AT+CIPSTATUS(弃用):查询TCP/UDP/SSL连接状态和信息 (57)3.3.4AT+CIPDOMAIN:域名解析 (58)3.3.5AT+CIPSTART:建立TCP连接、UDP传输或SSL连接 (58)3.3.6AT+CIPSTARTEX:建立自动分配ID的TCP连接、UDP传输或SSL连接 (62)3.3.7[仅适用数据模式]+++:退出数据模式 (62)3.3.8AT+CIPSEND:在普通传输模式或Wi-Fi透传模式下发送数据 (62)3.3.9AT+CIPSENDL:在普通传输模式下并行发送长数据 (63)3.3.10AT+CIPSENDLCFG:设置AT+CIPSENDL命令的属性 (65)3.3.11AT+CIPSENDEX:在普通传输模式下采用扩展的方式发送数据 (65)3.3.12AT+CIPCLOSE:关闭TCP/UDP/SSL连接 (66)3.3.13AT+CIFSR:查询本地IP地址和MAC地址 (67)3.3.14AT+CIPMUX:启用/禁用多连接模式 (68)3.3.15AT+CIPSERVER:建立/关闭TCP或SSL服务器 (69)3.3.16AT+CIPSERVERMAXCONN:查询/设置服务器允许建立的最大连接数 (70)3.3.17AT+CIPMODE:查询/设置传输模式 (71)3.3.18AT+SAVETRANSLINK:设置开机透传模式信息 (72)3.3.19AT+CIPSTO:查询/设置本地TCP/SSL服务器超时时间 (73)3.3.20AT+CIPSNTPCFG:查询/设置时区和SNTP服务器 (74)3.3.21AT+CIPSNTPTIME:查询SNTP时间 (75)3.3.22AT+CIPSNTPINTV:查询/设置SNTP时间同步的间隔 (76)3.3.23AT+CIUPDATE:通过Wi-Fi升级固件 (76)3.3.24AT+CIPDINFO:设置+IPD消息详情 (79)3.3.25AT+CIPSSLCCONF:查询/设置SSL客户端配置 (79)3.3.26AT+CIPSSLCCN:查询/设置SSL客户端的公用名(common name) (80)3.3.27AT+CIPSSLCSNI:查询/设置SSL客户端的SNI (81)3.3.28AT+CIPSSLCALPN:查询/设置SSL客户端ALPN (82)3.3.29AT+CIPSSLCPSK:查询/设置SSL客户端的PSK (82)3.3.30AT+CIPRECONNINTV:查询/设置Wi-Fi透传模式下的TCP/UDP/SSL重连间隔.833.3.31AT+CIPRECVMODE:查询/设置套接字接收模式 (84)3.3.32AT+CIPRECVDATA:获取被动接收模式下的套接字数据 (85)3.3.33AT+CIPRECVLEN:查询被动接收模式下套接字数据的长度 (86)3.3.34AT+PING:ping对端主机 (86)3.3.35AT+CIPDNS:查询/设置DNS服务器信息 (87)3.3.36AT+CIPTCPOPT:查询/设置套接字选项 (88)ii3.4Bluetooth®Low Energy AT命令集 (90)3.4.1AT+BLEINIT:Bluetooth LE初始化 (91)3.4.2AT+BLEADDR:设置Bluetooth LE设备地址 (92)3.4.3AT+BLENAME:查询/设置Bluetooth LE设备名称 (93)3.4.4AT+BLESCANPARAM:查询/设置Bluetooth LE扫描参数 (94)3.4.5AT+BLESCAN:使能Bluetooth LE扫描 (95)3.4.6AT+BLESCANRSPDATA:设置Bluetooth LE扫描响应 (96)3.4.7AT+BLEADVPARAM:查询/设置Bluetooth LE广播参数 (96)3.4.8AT+BLEADVDATA:设置Bluetooth LE广播数据 (98)3.4.9AT+BLEADVDATAEX:自动设置Bluetooth LE广播数据 (98)3.4.10AT+BLEADVSTART:开始Bluetooth LE广播 (99)3.4.11AT+BLEADVSTOP:停止Bluetooth LE广播 (100)3.4.12AT+BLECONN:建立Bluetooth LE连接 (100)3.4.13AT+BLECONNPARAM:查询/更新Bluetooth LE连接参数 (102)3.4.14AT+BLEDISCONN:断开Bluetooth LE连接 (103)3.4.15AT+BLEDATALEN:设置Bluetooth LE数据包长度 (103)3.4.16AT+BLECFGMTU:设置Bluetooth LE MTU长度 (104)3.4.17AT+BLEGATTSSRVCRE:GATTS创建服务 (105)3.4.18AT+BLEGATTSSRVSTART:GATTS开启服务 (106)3.4.19AT+BLEGATTSSRVSTOP:GATTS停止服务 (106)3.4.20AT+BLEGATTSSRV:GATTS发现服务 (107)3.4.21AT+BLEGATTSCHAR:GATTS发现服务特征 (108)3.4.22AT+BLEGATTSNTFY:服务器notify服务特征值给客户端 (108)3.4.23AT+BLEGATTSIND:服务器indicate服务特征值给客户端 (109)3.4.24AT+BLEGATTSSETATTR:GATTS设置服务特征值 (110)3.4.25AT+BLEGATTCPRIMSRV:GATTC发现基本服务 (111)3.4.26AT+BLEGATTCINCLSRV:GATTC发现包含的服务 (111)3.4.27AT+BLEGATTCCHAR:GATTC发现服务特征 (112)3.4.28AT+BLEGATTCRD:GATTC读取服务特征值 (113)3.4.29AT+BLEGATTCWR:GATTC写服务特征值 (114)3.4.30AT+BLESPPCFG:查询/设置Bluetooth LE SPP参数 (115)3.4.31AT+BLESPP:进入Bluetooth LE SPP模式 (116)3.4.32AT+BLESECPARAM:查询/设置Bluetooth LE加密参数 (117)3.4.33AT+BLEENC:发起Bluetooth LE加密请求 (118)3.4.34AT+BLEENCRSP:回复对端设备发起的配对请求 (119)3.4.35AT+BLEKEYREPLY:给对方设备回复密钥 (119)3.4.36AT+BLECONFREPLY:给对方设备回复确认结果(传统连接阶段) (120)3.4.37AT+BLEENCDEV:查询绑定的Bluetooth LE加密设备列表 (120)3.4.38AT+BLEENCCLEAR:清除Bluetooth LE加密设备列表 (121)3.4.39AT+BLESETKEY:设置Bluetooth LE静态配对密钥 (122)3.4.40AT+BLEHIDINIT:Bluetooth LE HID协议初始化 (122)3.4.41AT+BLEHIDKB:发送Bluetooth LE HID键盘信息 (123)3.4.42AT+BLEHIDMUS:发送Bluetooth LE HID鼠标信息 (124)3.4.43AT+BLEHIDCONSUMER:发送Bluetooth LE HID consumer信息 (125)3.4.44AT+BLUFI:开启或关闭BluFi (125)3.4.45AT+BLUFINAME:查询/设置BluFi设备名称 (126)3.4.46AT+BLEPERIODICDATA:设置Bluetooth LE周期性广播数据 (127)3.4.47AT+BLEPERIODICSTART:开启周期性广播 (128)3.4.48AT+BLEPERIODICSTOP:停止周期性广播同步 (128)3.4.49AT+BLESYNCSTART:开启同步周期性广播 (128)3.4.50AT+BLESYNCSTOP:停止周期性广播同步 (129)3.4.51AT+BLEREADPHY:查询当前连接使用的PHY (130)3.4.52AT+BLESETPHY:设置当前连接的PHY (130)3.5MQTT AT命令集 (131)3.5.1AT+MQTTUSERCFG:设置MQTT用户属性 (131)3.5.2AT+MQTTCLIENTID:设置MQTT客户端ID (132)3.5.3AT+MQTTUSERNAME:设置MQTT登陆用户名 (133)3.5.4AT+MQTTPASSWORD:设置MQTT登陆密码 (133)iii3.5.5AT+MQTTCONNCFG:设置MQTT连接属性 (134)3.5.6AT+MQTTALPN:设置MQTT应用层协议协商(ALPN) (134)3.5.7AT+MQTTCONN:连接MQTT Broker (135)3.5.8AT+MQTTPUB:发布MQTT消息(字符串) (136)3.5.9AT+MQTTPUBRAW:发布长MQTT消息 (137)3.5.10AT+MQTTSUB:订阅MQTT Topic (137)3.5.11AT+MQTTUNSUB:取消订阅MQTT Topic (138)3.5.12AT+MQTTCLEAN:断开MQTT连接 (139)3.5.13MQTT AT错误码 (139)3.5.14MQTT AT说明 (141)3.6HTTP AT命令集 (141)3.6.1AT+HTTPCLIENT:发送HTTP客户端请求 (141)3.6.2AT+HTTPGETSIZE:获取HTTP资源大小 (142)3.6.3AT+HTTPCGET:获取HTTP资源 (143)3.6.4AT+HTTPCPOST:Post指定长度的HTTP数据 (144)3.6.5AT+HTTPURLCFG:设置/获取长的HTTP URL (144)3.6.6HTTP AT错误码 (145)3.7信令测试AT命令 (146)3.7.1AT+FACTPLCP:发送长PLCP或短PLCP (146)3.8驱动AT命令 (146)3.8.1AT+DRVADC:读取ADC通道值 (146)3.8.2AT+DRVPWMINIT:初始化PWM驱动器 (147)3.8.3AT+DRVPWMDUTY:设置PWM占空比 (148)3.8.4AT+DRVPWMFADE:设置PWM渐变 (149)3.8.5AT+DRVI2CINIT:初始化I2C主机驱动 (149)3.8.6AT+DRVI2CRD:读取I2C数据 (150)3.8.7AT+DRVI2CWRDATA:写入I2C数据 (150)3.8.8AT+DRVI2CWRBYTES:写入不超过4字节的I2C数据 (151)3.8.9AT+DRVSPICONFGPIO:配置SPI GPIO (152)3.8.10AT+DRVSPIINIT:初始化SPI主机驱动 (152)3.8.11AT+DRVSPIRD:读取SPI数据 (153)3.8.12AT+DRVSPIWR:写入SPI数据 (154)3.9Web服务器AT命令 (154)3.9.1AT+WEBSERVER:启用/禁用通过Web服务器配置Wi-Fi连接 (155)3.10用户AT命令 (155)3.10.1AT+USERRAM:操作用户的空闲RAM (156)3.10.2AT+USEROTA:根据指定URL升级固件 (157)3.10.3AT+USERDOCS:查询固件对应的用户文档链接 (158)3.11AT命令分类 (159)3.12参数信息保存在flash中的AT命令 (159)3.13AT消息 (160)4AT命令示例1634.1TCP-IP AT示例 (163)4.1.1ESP32-C3设备作为TCP客户端建立单连接 (163)4.1.2ESP32-C3设备作为TCP服务器建立多连接 (165)4.1.3远端IP地址和端口固定的UDP通信 (166)4.1.4远端IP地址和端口可变的UDP通信 (168)4.1.5ESP32-C3设备作为SSL客户端建立单连接 (170)4.1.6ESP32-C3设备作为SSL服务器建立多连接 (171)4.1.7ESP32-C3设备作为SSL客户端建立双向认证单连接 (173)4.1.8ESP32-C3设备作为SSL服务器建立双向认证多连接 (175)4.1.9ESP32-C3设备作为TCP客户端,建立单连接,实现UART Wi-Fi透传 (178)4.1.10ESP32-C3设备作为TCP服务器,实现UART Wi-Fi透传 (179)4.1.11ESP32-C3设备作为softAP在UDP传输中实现UART Wi-Fi透传 (181)4.2Bluetooth LE AT示例 (183)4.2.1简介 (183)4.2.2Bluetooth LE客户端读写服务特征值 (184)iv4.2.3Bluetooth LE服务端读写服务特征值 (188)4.2.4Bluetooth LE连接加密 (193)4.2.5两个ESP32-C3开发板之间建立SPP连接,以及在UART-Bluetooth LE透传模式下传输数据 (197)4.2.6ESP32-C3与手机建立SPP连接,以及在UART-Bluetooth LE透传模式下传输数据2014.3MQTT AT示例 (203)4.3.1基于TCP的MQTT连接(需要本地创建MQTT代理)(适用于数据量少) (203)4.3.2基于TCP的MQTT连接(需要本地创建MQTT代理)(适用于数据量多) (205)4.3.3基于TLS的MQTT连接(需要本地创建MQTT代理) (206)4.3.4基于WSS的MQTT连接 (208)4.4MQTT AT连接云示例 (209)4.4.1从AWS IoT获取证书以及endpoint (210)4.4.2使用MQTT AT命令基于双向认证连接AWS IoT (210)4.5Web Server AT示例 (212)4.5.1使用浏览器进行Wi-Fi配网 (214)4.5.2使用浏览器进行OTA固件升级 (215)4.5.3使用微信小程序进行Wi-Fi配网 (222)4.5.4使用微信小程序进行OTA固件升级 (232)4.5.5ESP32-C3使用Captive Portal功能 (232)4.6HTTP AT示例 (233)4.6.1HTTP客户端HEAD请求方法 (233)4.6.2HTTP客户端GET请求方法 (234)4.6.3HTTP客户端POST请求方法(适用于POST少量数据) (235)4.6.4HTTP客户端POST请求方法(推荐方式) (236)4.6.5HTTP客户端PUT请求方法 (238)4.6.6HTTP客户端DELETE请求方法 (239)4.7Sleep AT示例 (240)4.7.1简介 (241)4.7.2在Wi-Fi模式下设置为Modem-sleep模式 (241)4.7.3在Wi-Fi模式下设置为Light-sleep模式 (243)4.7.4在蓝牙广播态下设置为Modem-sleep模式 (243)4.7.5在蓝牙连接态下设置为Modem-sleep模式 (244)4.7.6在蓝牙广播态下设置为Light-sleep模式 (245)4.7.7在蓝牙连接态下设置为Light-sleep模式 (246)4.7.8设置为Deep-sleep模式 (247)5如何编译和开发自己的AT工程2495.1编译ESP-AT工程 (249)5.1.1详细步骤 (249)5.1.2第一步:ESP-IDF快速入门 (249)5.1.3第二步:获取ESP-AT (250)5.1.4第三步:安装环境 (250)5.1.5第四步:连接设备 (250)5.1.6第五步:配置工程 (251)5.1.7第六步:编译工程 (251)5.1.8第七步:烧录到设备 (251)5.1.9build.py进阶用法 (252)5.2如何设置AT端口管脚 (252)5.2.1ESP32-C3系列 (252)5.3添加自定义AT命令 (253)5.3.1定义AT命令 (253)5.3.2注册AT命令 (255)5.3.3尝试一下吧 (255)5.3.4定义返回消息 (256)5.3.5获取命令参数 (257)5.3.6省略命令参数 (257)5.3.7阻塞命令的执行 (260)5.3.8从AT命令端口获取输入的数据 (260)v5.4如何提高ESP-AT吞吐性能 (263)5.4.1[简单]快速配置 (264)5.4.2[推荐]熟悉数据流、针对性地配置 (264)5.5如何生成出厂参数二进制文件 (267)5.5.1factory_param_type.csv (267)5.5.2factory_param_data.csv (267)5.5.3新增一个自定义模组 (268)5.5.4新增一个自定义参数 (270)5.5.5修改现有模组的出厂参数数据 (271)5.6如何自定义低功耗蓝牙服务 (273)5.6.1低功耗蓝牙服务源文件 (273)5.6.2自定义低功耗蓝牙服务 (274)5.7如何自定义分区 (276)5.7.1修改at_customize.csv (276)5.7.2生成at_customize.bin (277)5.7.3烧录at_customize.bin至ESP32-C3设备 (277)5.7.4示例 (277)5.8如何增加一个新的模组支持 (278)5.8.1在factory_param_data.csv添加模组信息 (278)5.8.2修改esp_at_module_info结构体 (279)5.8.3配置模组文件 (279)5.9SPI AT指南 (279)5.9.1简介 (280)5.9.2使用SPI AT (281)5.9.3SPI AT速率 (283)5.10如何实现OTA升级 (284)5.10.1OTA命令对比及应用场景 (284)5.10.2使用ESP-AT OTA命令执行OTA升级 (285)5.11如何更新ESP-IDF版本 (288)5.12ESP-AT固件差异 (291)5.12.1ESP32-C3系列 (291)5.13如何从GitHub下载最新临时版本AT固件 (292)5.14自定义Bluetooth LE Services工具 (293)5.14.1生成二进制文件 (298)5.14.2下载或者更新二进制文件 (298)5.15如何生成PKI文件 (300)5.15.1证书二进制文件格式 (300)5.15.2生成证书二进制文件 (301)5.15.3下载或者更新证书二进制文件 (301)5.16AT API Reference (303)5.16.1Header File (303)5.16.2Functions (303)5.16.3Structures (307)5.16.4Macros (309)5.16.5Type Definitions (309)5.16.6Enumerations (310)5.16.7Header File (312)5.16.8Functions (312)5.16.9Macros (312)6第三方定制化AT命令和固件3136.1腾讯云IoT AT命令和固件 (313)6.1.1腾讯云IoT AT命令集 (313)6.1.2Tencent Cloud IoT AT Firmware (351)7AT FAQ3537.1AT固件 (353)7.1.1我的模组没有官方发布的固件,如何获取适用的固件? (354)vi7.1.2如何获取AT固件源码? (354)7.1.3官网上放置的AT固件如何下载? (354)7.1.4如何整合ESP-AT编译出来的所有bin文件? (354)7.1.5模组出厂AT固件是否支持流控? (354)7.2AT命令与响应 (354)7.2.1AT提示busy是什么原因? (354)7.2.2AT固件,上电后发送第一个命令总是会返回下面的信息,为什么? (354)7.2.3在不同模组上的默认AT固件支持哪些命令,以及哪些命令从哪个版本开始支持?3557.2.4主MCU给ESP32-C3设备发AT命令无返回,是什么原因? (355)7.2.5ESP-AT命令是否支持ESP-WIFI-MESH? (355)7.2.6AT是否支持websocket命令? (355)7.2.7是否有AT命令连接阿里云以及腾讯云示例? (355)7.2.8AT命令是否可以设置低功耗蓝牙发射功率? (355)7.2.9如何支持那些默认固件不支持但可以在配置和编译ESP-AT工程后支持的命令?.3557.2.10AT命令中特殊字符如何处理? (355)7.2.11AT命令中串口波特率是否可以修改?(默认:115200) (355)7.2.12ESP32-C3使用AT指令进入透传模式,如果连接的热点断开,ESP32-C3能否给出相应的提示信息? (356)7.2.13ADV广播参数超过32字节之后应该如何设置? (356)7.3硬件 (356)7.3.1在不同模组上的AT固件要求芯片flash多大? (356)7.3.2AT固件如何查看error log? (356)7.3.3AT在ESP32-C3模组上的UART1通信管脚与ESP32-C3模组的datasheet默认UART1管脚不一致? (356)7.4性能 (356)7.4.1AT Wi-Fi连接耗时多少? (356)7.4.2ESP-AT固件中TCP发送窗口大小是否可以修改? (356)7.4.3ESP32-C3AT吞吐量如何测试及优化? (357)7.5其他 (357)7.5.1乐鑫芯片可以通过哪些接口来传输AT命令? (357)7.5.2ESP32-C3AT如何指定TLS协议版本? (357)7.5.3AT固件如何修改TCP连接数? (357)8Index of Abbreviations359 9关于ESP-AT363索引365索引365viiviiiTable of contents这里是乐鑫ESP-AT开发框架的文档中心。
